FORSV : Forum de Sciences et de Vie

Forum scientifique
 
AccueilAccueil  GalerieGalerie  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Formule excel besoin d'aide

Aller en bas 
AuteurMessage
Leeloo



Nombre de messages : 454
Date d'inscription : 23/09/2007

MessageSujet: Formule excel besoin d'aide   Mar 8 Avr 2014 - 12:00

Salut tout le monde  cheers 

Je suis coincee avec une formule d'excel:
J'ai 3 indexs: plus grand que 3 ==> 1 , plus petit que 1 ==> 3 et entre les deux 2.
Pour l'instant j'ai ca :

=IF(A1>2,IF(A1>=3,1,2),3)

mais je veux aussi que si A1=NA alors ==> blank (que le cell reste vide)

comment j'allie les deux ? j'ai essaye IF dans IF, j'ai essaye AND, j'y arrive pas...
et sur les forums je ne trouve pas...


Merci d'avance !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Steph



Nombre de messages : 7938
Date d'inscription : 09/03/2007

MessageSujet: Re: Formule excel besoin d'aide   Mar 8 Avr 2014 - 13:39

Salut leeloo,

Le premier terme après le test est le VRAI (la condition est respectée)
On sépare avec des point virgule (semicolon en anglais)

Si A<1 --> 3
Sinon nouveau test
Si A>3 --> 1
Sinon: 2

Ce qui se traduit par:

=IF(A1<1; 3; (IF(A1>3; 1;2)))

Si tu veux rajouter un dernier test alors tu dois faire un test dans le résultat FAUX de ton second test (en l'occurence A>3):

Si A1<1 est FAUX et que A1>3 est FAUX, alors tu fais un test supplémentaire: A1=xx
Inutile de dire que le terme de l'égalité (que tu as noté NA) doit se trouver entre 1 et 3 (compris).

a toi de jouer (le blanc c'est 2 guillemets """ou un 0, selon le format de la cellule)
je te laisse implémenter le dernier test pour voir si tu as tout compris.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Leeloo



Nombre de messages : 454
Date d'inscription : 23/09/2007

MessageSujet: Re: Formule excel besoin d'aide   Mar 8 Avr 2014 - 14:54

Merci j'essaye je te tiens au courant
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Steph



Nombre de messages : 7938
Date d'inscription : 09/03/2007

MessageSujet: Re: Formule excel besoin d'aide   Mer 9 Avr 2014 - 9:23

Et ca donne quoi après une bonne nuit de sommeil?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ji_louis

avatar

Nombre de messages : 2008
Localisation : près de la mer
Date d'inscription : 13/02/2007

MessageSujet: Re: Formule excel besoin d'aide   Mer 9 Avr 2014 - 19:18

Leeloo a écrit:
Je suis coincee avec une formule d'excel:
J'ai 3 indexs: plus grand que 3 ==> 1 , plus petit que 1 ==> 3 et entre les deux 2.

...

mais je veux aussi que si A1=NA alors ==> blank (que le cell reste vide)
Salut miss Wink

En partant de l'hypothèse que tu as tes index dans la cellule A1 (en haut à gauche), tu mets la formule suivante dans ta cellule à calculer :
Code:
=SI(A1>3;3;SI(ESTNA(A1);"N/A";SI(A1<1;1;2)))

ce qui avec la version anglophone devrait faire:
Code:
=IF(A1>3;3;IF(ISNA(A1);"N/A";IF(A1<1;1;2)))

ATTENTION, une cellule vide vaut 0 et te donnera le résultat 1  Shocked 
Pour éviter cela, il faut:
Code:
=SI(A1>3;3;SI(ESTNA(A1);"N/A";SI(ESTVIDE(A1);"vide";SI(A1<1;1;2))))
Code:
=IF(A1>3;3;IF(ISNA(A1);"N/A";IF(ISEMPTY(A1);"vide";IF(A1<1;1;2))))

Bien sur, tu remplace "N/A" et "vide" par le résultat que tu veux Wink

ESTNA (ISNA) détecte les valeurs d'erreur #N/A
ESTVIDE (ISEMPTY) détecte si il y a ou pas du contenu dans la cellule
ESTERR (ISERR)  détecte toutes les autres valeurs d'erreurs possibles
@+
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.octaam.net/
Leeloo



Nombre de messages : 454
Date d'inscription : 23/09/2007

MessageSujet: Re: Formule excel besoin d'aide   Jeu 22 Mai 2014 - 14:21

Merci Ji-Louis...ca y est j'ai pige....
Comment va la famille ? comment va mon homonyme ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ji_louis

avatar

Nombre de messages : 2008
Localisation : près de la mer
Date d'inscription : 13/02/2007

MessageSujet: Re: Formule excel besoin d'aide   Sam 24 Mai 2014 - 15:49

réponse par message privé Wink
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.octaam.net/
Contenu sponsorisé




MessageSujet: Re: Formule excel besoin d'aide   

Revenir en haut Aller en bas
 
Formule excel besoin d'aide
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Besoin d'aide . Fournitures scolaires ...
» Besoin d''aide en épistémologie de la géographie
» besoin d'aide pour mon cas pratique de droit
» Lecture d'image : besoin d'aide !
» LA ROUMANIE A BESOIN D'AIDE

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
FORSV : Forum de Sciences et de Vie :: Sciences :: Mathématiques-
Sauter vers: